Account
 
 
 
0
 
 
14 Mar

Wordpress Privacy Policies Plugin

Facebook, Twitter, Flattr - all of these services provide tools such as the 'Like' button, the 'ReTweet' button or a 'Donate' button. If you use one of these or a similar tool on your website, you run the risk of receiving a warning. By simply loading the website and the subsequent loading of these tools, your customers' data will be transmitted to the respective server of these services. According to current laws and regulations, however, this violates data privacy issues. Legal safety can only be achieved by requesting the user's agreement by an active click on loading the plug-in.

For this purpose, we have developed a completely free Wordpress plug-in!

The Wordpress Data Safety Plug-in allows you to receive the agreement of your website users BEFORE loading any legally suspect tools such as Facebook or Twitter buttons in the first place.

On their first visit to the site, the Wordpress Data Safety Plug-in requests all users to agree to using these services once. This Agreement is secured by a pop-up box that will appear only once and does the following:

1) it informs the user on why this box has popped up
2) it shows the user the Privacy Policy on using external services
3) it requires the user to either accept or reject the Policy.

This plug-in ensures that users do not have to agree for each tool individually and thus prevents them from getting frustrated by doing so. If a user rejects the Policy, he will be shown a note in place of the tools, informing him that the rejection of the conditions has lead to a hiding of tools here. The user can agree to the conditions any time afterwards.

Easy-to-use services!

The plug-in allows users to cover each and every service for which the tools can be included by a code on one's own site by the Agreement Process for users. Codes are consequently no longer directly fed into the Content or Theme but will now be fed into the Wordpress Data Safety Plug-in by using the Backend. The plug-in will automatically create 2 short tags from each entered code. These short tags can be inserted into the Wordpress Content or the Wordpress Theme in the same way as you used to enter the Tool Code.

It's good to know that the plug-in can basically also be used for other purposes. For example, you can also insert images, tacking codes or texts into the plug-in. The user can only see these contents after agreeing to the Policy.

No frustrated users!

When the user has agreed to the Conditions, the plug-in activates a so-called cookie for the user. This cookie is designed for the long term, ensuring that the user won't have to agree to the conditions again and again for each loading and visiting of the website. After all, you don't want to bother your users by a permanently popping up note. A renewed agreement will only be required when the user explicitly deletes the cookie stored by the plug-in from his computer. This way, you ensure that it is completely up to the user whether and when the note will pop up.

Legal texts created by law firm!

The texts on the Data Privacy contained in the plug-in have been created by the law firm ResMedia and inform the user on the usage of the respective services. All legal texts contained will be kept up to date with future updates of the plug-in if applicable. As required by law, the user will thus be informed of the sharing of his or her data before loading any tools.

Various themes available!

Simply use the configuration to select the look of the note box for the agreement to the Policy. You can choose from 12 different themes. In case you don't like any of the existing themes, everything can of course be freely customized by css and replacing graphic elements.

Posted by YannickS on in News
Rate this blog entry:
3
9 Comments  
 
 

Comments

  • Klaus Tuesday, 10 July 2012

    Leider arbeitet das Plugin nicht mit dem WP Super Cache zusammen.
    Es erscheint, obwohl man auf akzeptieren geklickt hat, auf jeder Seite die Datenschutzerklärung. Das liegt wohl daran das kein Cookie gesetzt wird dann.

    Beim Graphene Theme und Verwendung als TOP-Bar wird die Datenschutzerklärung hinter der wagerechten Menüleiste angezeigt. Also Teilweise überdeckt...

     
  • ripu@ripucom.de Saturday, 21 July 2012

    Hallo Klaus,

    das Plugin kann nicht mit WP Super Cache zusammenarbeiten. WP Super Cache generiert statische HTML-Dokumente, die jedem Gast ausgegeben werden. Das Problem hierbei ist, dass der PHP-Code, welcher unebdingt zur Funktionalität des Plugins beiträgt, nun nicht mehr ausgeführt wird.

    Bezüglich des Graphene Themes würde ich mich über einen Demo-Link freuen, um Deinen Post besser nachvollziehen zu können.

     
  • Dissertation Literature Review Wednesday, 13 January 2010

    On their first visit to the site, the Wordpress Data Safety Plug-in requests all users to agree to using these services once.

     
  • Karsten Saturday, 06 October 2012

    Hallo,
    das Plugin finde ich sehr interessant, mich wundert nur, dass ihr es nicht selbst auf Eurer Seite einsetzt?! Mir wurde es jedenfalls nicht eingeblendet. Ich habe auch Bedenken, dass dadurch viele Interessenten von dem eigentlichen Inhalt meiner Seite ferngehalten werden, gibt es hierüber Erfahrungen?

     
  • YannickS Saturday, 06 October 2012

    Hallo Karsten,

    wir nutzen auf unserer Webseite kein Wordpress. Darum kann das Plugin natürlich nicht auf unserer Webseite laufen - eine eigene Lösung für Joomla! für unsere eigene Seite steht leider noch aus.

    Beste Grüße,
    Yannick

     
  • Klaus-Dieter Saturday, 12 January 2013

    Hallo,
    das Plugin finde ich sehr gut, allerdings würde ich es gerne einsetzen, um mich datenschutzrechtlich bei der Nutzung der Ebay- und Amazon Affiliate/Partner-Programme abzusichern. Auch dort werden Nutzerdaten in die USA übertragen, allerdings nicht nur durch Plugins sondern auch durch einfachen Klick auf einen Affiliate-Link.
    Kann das Plugin dafür verwendet werden?
    Man müsste dann irgendwie die Links in den Artikeln ändern oder löschen lassen, falls der Nutzer der Erklärung nicht zustimmt...

     
  • eyepic Thursday, 05 September 2013

    Hallo, ich bin von Ihrem Plugin begeistert und bisher immer zufrieden gewesen. Mit dem Update meiner WP Version auf 3.6 haben sich allerdings Probleme ergeben. Das Popupfenster erscheint nicht mehr und Ihr Plugin verhindert, dass man die Menüs und andere Elemente im Backend verschieben lassen. Ich würde Ihr Plugin gerne weiterhin nutzen, gibt es für die o.g. Probleme eine Lösung?

     
  • YannickS Monday, 09 September 2013

    Hallo eyepic,

    wir werden das überprüfen gerneund dann ein Upate veröffentlichen. Können Sie sich bitte per Mail melden und das Problem genauer beschreiben? Ggf. senden Sie uns auch eine URL zum testen,

    http://www.yagendoo.com/de/support/sales.html

    Beste Grüße
    Yannick

     
  • MADxHAWK Monday, 14 October 2013

    Hallo,

    einwirklich klasse Plugin, vielen Dank dafür. Eine Frage hätte ich jedoch. Ist es moglich das Plugin Mobiltauglich zu machen? Ich nutze ein auf Bootstrap und ein auf Foundation basierendes Responsive Mobile-First Theme. Leider wird hier das Popup jedoch nicht entsprechend angepasst. Wäre klasse, wenn es da eine Möglichkeit gäbe.

    Gruss
    MAD

     

Guest  Saturday, 03 December 2016

 

Looking for a developer?

We´re on your side if you run in problems or we create you whole new websites and onlineshops!

Yagendoo Media Team

Get a quote!

» Portfolio «